filebot failing to find "tosh 0" on thetvdb

Any questions? Need some help?
Post Reply
belgarth
Posts: 30
Joined: 25 Jan 2012, 09:19

filebot failing to find "tosh 0" on thetvdb

Post by belgarth » 08 Mar 2012, 21:58

[email protected]:~/Downloads/TV-Shows/Unsorted$ filebot --q "Tosh 0" -list --db thetvdb
Exception: Failed to auto-select search result: []
Failure (°_°)
[email protected]:~/Downloads/TV-Shows/Unsorted$ filebot --q "Tosh.0" -list --db thetvdb
Tosh.0 - 1x01 - Afro Ninja
Tosh.0 - 1x02 - Miss South Carolina
Tosh.0 - 1x03 - News Puke Kid
Tosh.0 - 1x04 - Scarlet Takes a Tumble
...

This creates a problem because the epsiode autodetector detects from the filename as "Tosh 0", not "Tosh.0":
[email protected]:~/Downloads/TV-Shows/Unsorted$ ls
tosh.0.s04e06.720p.hdtv.x264-momentum.mkv
[email protected]:~/Downloads/TV-Shows/Unsorted$ filebot --q "Tosh 0" -non-strict -rename --db thetvdb --format "/home/belgarth/Downloads/TV-Shows/{n}/{n} - {s}x{e} - {t}" /home/belgarth/Downloads/TV-Shows/Unsorted/*
Rename episodes using [TheTVDB]
Failed to fetch episode data: [Tosh 0]
Exception: Unable to match files to episode data
Failure (°_°)
so it fails to match.

tvrage doesn't have this problem, it appears to be specific to thetvdb. When I do a search on "Tosh 0" though, it does find the show.

User avatar
rednoah
The Source
Posts: 17470
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: filebot failing to find "tosh 0" on thetvdb

Post by rednoah » 09 Mar 2012, 02:22

Yep, TheTVDB query engine fails on stuff like this because it sees "tosh.0" as one word. Search by "tosh" and "0" doesn't work in this case.

@see
http://www.thetvdb.com/api/GetSeries.ph ... anguage=en VS http://www.thetvdb.com/api/GetSeries.ph ... anguage=en

You can check in the tvdb api forums, I'm pretty sure this is a well-known issue that hopefully get's fixed with the coming API overhaul.
:idea: Please read the FAQ and How to Request Help.

Post Reply