This package requires DSM version 0.0-0000 or onward

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
aglyons
Posts: 19
Joined: 29 Dec 2020, 18:42

This package requires DSM version 0.0-0000 or onward

Post by aglyons »

Just went to update to 4.9.4 on Synology DSM 6.2.4-25556 and rec'd the error message;

Code: Select all

"This package requires DSM version 0.0-0000 or onward."
The package won't update and it looks like the required DSM version number might have been coded wrong.
User avatar
rednoah
The Source
Posts: 23073
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Synology 4.9.4 update error message

Post by rednoah »

:?: Which package source are you using?

rednoah wrote: 10 Jul 2014, 06:56 ⭑⭑ As of FileBot 4.9.4, the main package repository is DSM 7 only. If you are using DSM 6.2.4, please switch to the second package repository. ⭑⭑



Add Package Source:
Package Center ► Settings ► Package Sources ► Add ► Name: FileBot and Location: https://get.filebot.net/syno/

DSM 7 and higher:

Code: Select all

https://get.filebot.net/syno/
DSM 6.2.4:

Code: Select all

https://get.filebot.net/syno/dsm6.json
:idea: Please read the FAQ and How to Request Help.
arachne
Posts: 9
Joined: 24 Apr 2013, 08:59

Re: Synology 4.9.4 update error message

Post by arachne »

I just got this error as well.
I'm using https://get.filebot.net/syno/ as the package source. But, aha, I see my DSM is still 6.2.4. I'll update to DSM 7 (I was going to do that anyway!) and reconfirm.
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

A question out of curiosity. I was using https://get.filebot.net/syno/ with DSM 6.2.4. without any issues, until now (Node became useless, task seems still to work though). Could it be that this is related to Update 7 of DSM 6.2.4? Why was I not earlier affected? What would be the recommendation, using https://get.filebot.net/syno/dsm6.json or upgrading to DSM 7?
User avatar
rednoah
The Source
Posts: 23073
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: This package requires DSM version 0.0-0000 or onward

Post by rednoah »

:idea: If you are using DSM 6.2.4 then you must use https://get.filebot.net/syno/dsm6.json as package source. If you use https://get.filebot.net/syno/ as package source on your DSM 6.* then your DSM 6.* will download DSM 7.* packages and find them incompatible. This change was made in 2021 so you have not been getting any automatic updates from us since then.



:?: I don't know if DSM 6.2.4 Update 7 somehow breaks pre-2021 versions of FileBot Node. It is possible. I'd start by restarting the NAS and following the general FileBot Node Troubleshooting guide. What does the log say?


rednoah wrote: 10 Jul 2014, 06:56 ⭑⭑ As of FileBot 4.9.4, the main package repository is DSM 7 only. If you are using DSM 6.2.4, please switch to the second package repository. ⭑⭑



Add Package Source:
Package Center ► Settings ► Package Sources ► Add ► Name: FileBot and Location: https://get.filebot.net/syno/

DSM 7 and higher:

Code: Select all

https://get.filebot.net/syno/
DSM 6.2.4:

Code: Select all

https://get.filebot.net/syno/dsm6.json
:arrow: https://www.filebot.net/linux/syno.html
:idea: Please read the FAQ and How to Request Help.
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

Thank you for the reply. I changed the Package Source to https://get.filebot.net/syno/dsm6.json and Java Installer and FileBot updated without a problem. However, FileBot Node has disappeared and I got an error message on the Oracle Java SE. Should I reinstall it as suggested or would there be another way to solve this problem? Tried to post the image, hope it worked.
https://ibb.co/bWRQcK0
User avatar
rednoah
The Source
Posts: 23073
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: This package requires DSM version 0.0-0000 or onward

Post by rednoah »

1.
The Oracle Java SE package is defunct and no longer exists. The Java Installer package is the only package that should be used to install the java binaries. Please remove all the packages you may have installed ages ago, and then only install the packages provided by the https://get.filebot.net/syno/dsm6.json repository.


2.
FileBot Node is in the package repository, so DSM package manager will show it, if not then clicking the Image Refresh button is worth a try:
https://get.filebot.net/syno/dsm6.json

Image
:idea: Please read the FAQ and How to Request Help.
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

Thanks for the reply. I will try to have my spring cleaning this weekend and will report back once done. Hopefully it will work...
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

I changed repo to dsm6 and uninstalled dsm.filebot-node.conf and reinstalled FileBot Node. It is now running 5.0.3 (r9760). When I do a Dry Run I get the Exit Code: 4. What am I still missing? Here is the log:


Code: Select all

filebot -script 'fn:amc' /volume1/torrents/Movies/ --output /volume1/XBMC/Movies/ --action TEST -non-strict --order Airdate --conflict auto --lang en --def 'ut_label=Movie' 'music=y' 'unsorted=y' 'skipExtract=y' 'exec=/volume1/Shared/UpdateV.sh' 'seriesFormat={n}/{n} - Season {s}/{n} - {s00e00} - {t}' 'movieFormat={n} ({y})' 'excludeList=.excludes' --apply refresh --log all --log-file '/var/packages/filebot-node/target/data/filebot.log'

------------------------------------------

Run script [fn:amc] at [Tue Jun 06 21:59:37 CEST 2023]

[PSA] Important Discussion of Proposed Changes:
https://www.filebot.net/forums/viewtopic.php?t=13406

Parameter: ut_label = Movie
Parameter: music = y
Parameter: unsorted = y
Parameter: skipExtract = y
Parameter: exec = /volume1/Shared/UpdateV.sh
Parameter: seriesFormat = {n}/{n} - Season {s}/{n} - {s00e00} - {t}
Parameter: movieFormat = {n} ({y})
Parameter: excludeList = .excludes
Argument[0]: File does not exist: /volume1/torrents/Movies
[TEST] --def unsorted is incompatible with --action TEST and has been disabled
Invalid usage: output folder must exist and must be a writable directory: /volume1/XBMC/Movies
Use excludes: /volume1/XBMC/Movies/.excludes
Failed to create excludes: /volume1/XBMC/Movies/.excludes
Abort (×_×)

------------------------------------------

[Process error]

🔺 Exit Code: 4
User avatar
rednoah
The Source
Posts: 23073
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: This package requires DSM version 0.0-0000 or onward

Post by rednoah »

The log indicates that FileBot Node does not have read/write permissions for the given output folder:

Code: Select all

Invalid usage: output folder must exist and must be a writable directory: /volume1/XBMC/Movies

Code: Select all

Failed to create excludes: /volume1/XBMC/Movies/.excludes


:?: Did you grant read/write permissions?
rednoah wrote: 10 Jul 2014, 06:56 Package Permissions:
DSM 6.2.4 and DSM 7.0 restrict file system access by default. FileBot Node may not be able to access your files unless you explicitly grant permission first.

Image
:idea: Please read the FAQ and How to Request Help.
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

Dry Run went well. Will create some tasks later and see if they work - I am quite confident they will. Thanks a lot for your expert help!
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

Apologies for my ignorance, but how do I schedule a task now with dsm6? Do I have to use the link or cURL? Do I have to copy paste it in the task manager under "user-defined script" or is there another way to run FilebBot daily?
User avatar
rednoah
The Source
Posts: 23073
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: This package requires DSM version 0.0-0000 or onward

Post by rednoah »

holsten wrote: 12 Jun 2023, 19:30 Do I have to copy paste it in the task manager under "user-defined script"
Yes. That's what FileBot did for you in the past, but now you have to do it yourself.



:arrow: You can open the Synology Task Scheduler and create a task manually with the given command:

Shell: Select all

filebot-node-task 8
Screenshot
:idea: Please read the FAQ and How to Request Help.
holsten
Posts: 17
Joined: 15 Nov 2015, 14:38

Re: This package requires DSM version 0.0-0000 or onward

Post by holsten »

It actually was in the message, but I was too numb to see it ;) Thanks now it's all working again, your help is highly appreciated!
Post Reply