rtorrent not launch my script

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
drsky
Posts: 2
Joined: 08 Sep 2019, 13:00

rtorrent not launch my script

Post by drsky » 12 Oct 2019, 22:24

hello, i'm trying to run filebot when a torrent ends, but it seems that rtorrent does not launch filebot at the end of the torrents.

.rtorrent.rc :

Code: Select all

etwork.scgi.open_port = 127.0.0.1:5001
encoding.add = UTF-8
network.port_range.set = 45000-65000
network.port_random.set = no
pieces.hash.on_completion.set = no
directory.default.set = /home/tout/torrents
session.path.set = /home/tout/.session
protocol.encryption.set = allow_incoming, try_outgoing, enable_retry
schedule2 = watch_directory,1,1,load.start=/home/tout/watch/*.torrent
schedule2 = untied_directory,5,5,stop_untied=/home/tout/watch/*.torrent
schedule2 = espace_disque_insuffisant,1,30,close_low_diskspace=500M
trackers.use_udp.set = yes
dht.mode.set = off
protocol.pex.set = no
throttle.min_peers.normal.set = 40
throttle.max_peers.normal.set = 100
throttle.min_peers.seed.set = 10
throttle.max_peers.seed.set = 50
throttle.max_uploads.set = 15
execute2 = {sh,-c,/usr/bin/php /var/www/rutorrent/php/initplugins.php tout &}
method.set_key = event.download.finished,filebot_amc,"execute.nothrow.bg={/home/tout/rtorrent-postprocess,$d.get_base_path=,$d.get_name=,$d.get_custom1=}"
rtorrent-postprocess :

Code: Select all

#!/bin/bash
TORRENT_PATH=$1
TORRENT_NAME=$2
TORRENT_LABEL=$3
filebot -script fn:sysenv > "/home/tout/log.txt" 2>&1
filebot --lang fr -script fn:amc --output "/home/tout/Media" --log-file "/home/tout/.session/amc.log" --action symlink --conflict override -non-strict --def music=y artwork=y "ut_dir=$TORRENT_PATH" "ut_kind=multi" "ut_title=$TORRENT_NAME" "ut_label=$TORRENT_LABEL" &
if anyone has an idea thank you in advance

User avatar
rednoah
The Source
Posts: 16615
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: rtorrent not launch my script

Post by rednoah » 13 Oct 2019, 01:08

Here's some general help:
viewtopic.php?t=3067


You may or may not have read this already:
viewtopic.php?f=4&t=215#p5316


There seem to be different versions of rT around that work slightly different. What version of rT are you using?
viewtopic.php?f=4&t=4765


:idea: But generally speaking, if rT isn't calling FileBot in the first place, then you may find more qualified help in the rT forums. Please keep up posted here as well though if you find a solution.
:idea: Please read the FAQ and How to Request Help.

Post Reply