Filebot does not work recursively (filebot -r -script fn:artwork.tmdb)

All your suggestions, requests and ideas for future development
Post Reply
mapomme1108
Posts: 6
Joined: 04 Jun 2015, 09:18

Filebot does not work recursively (filebot -r -script fn:artwork.tmdb)

Post by mapomme1108 » 23 Mar 2020, 22:25

Hello,

I have installed Filebot 4.9.0 on Debian 10.0.3 x64

I want to use this command line :

Code: Select all

filebot -r -script fn:artwork.tmdb -non-strict /home/user/Vidéos/Films
But the -r argument does not work. Filebot does not see the subfolders in the Films folder.

It works if I use the same command line with the subfolder of the movie:

Code: Select all

filebot -r -script fn:artwork.tmdb -non-strict /home/user/Vidéos/Films/(2016) name-of-the-movie"
What should I do to make the

Code: Select all

-r
argument work?

Thanks!

User avatar
rednoah
The Source
Posts: 17864
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Filebot does not work recursively

Post by rednoah » 24 Mar 2020, 06:02

The artwork.* scripts require an input folder as argument. By specifying -r the script is not passed a single input folder, but instead a set of files, i.e. the input folder argument is resolved recursively by filebot before being passed on to the script.

Code: Select all

filebot -script fn:artwork.tmdb /path/to/movies/
:arrow: viewtopic.php?p=205#p205


TL;DR -r breaks the script. Remove -r and it'll work.
:idea: Please read the FAQ and How to Request Help.

mapomme1108
Posts: 6
Joined: 04 Jun 2015, 09:18

Re: Filebot does not work recursively (filebot -r -script fn:artwork.tmdb)

Post by mapomme1108 » 25 Mar 2020, 13:13

Hello,

It works!! Thank you!!

Post Reply