Plex + filebot: splitted movies issue

All your suggestions, requests and ideas for future development
Post Reply
natopigro
Posts: 1
Joined: 23 Jun 2020, 09:45

Plex + filebot: splitted movies issue

Post by natopigro » 23 Jun 2020, 09:49

I recently moved to filebot. It would be very useful to me adding some information to the file name, such as codec, resolution, bitrate.
I use the following format:

Code: Select all

E:/{plex.derive{" [$vf, $kbps, $vc, $ac]"}}
which gives, for example,

Code: Select all

E:\Movies\Some Like It Hot (1959)\Some Like It Hot (1959) [360p, 850 kbps, DivX, MP3].avi
and Plex correctly recognize the movie. Great.

The problem arise dealing with movies splitted:

Code: Select all

E:\Movies\Avatar (2009)\Avatar (2009)  **CD1**  [360p, 1076 kbps, XviD, MP3].avi
Plex can't recognize this properly. I know the guidelines and it should be named
E:\Movies\Avatar (2009)\Avatar (2009) - cd1.avi
Here are my questions:
1_ why filebot rename uncorrectly with the "CD1", capital and without the "-"?
2_ the Plex scraping is more robust than it claims to be (see my first example). Is it possible somehow to keep my renaming format and bypass the splitted movie issue?

User avatar
rednoah
The Source
Posts: 18537
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Plex + filebot: splitted movies issue

Post by rednoah » 23 Jun 2020, 10:23

FileBot doesn't care about any particular pattern in the original file name nor does it try to preserve any. I suppose File.derive() doesn't quite work the way we want in this case, because the CD1 part should be at the end of the filename?


I suppose {plex} is limited in this regard, but you can always write your own format entirely, instead of relying on {plex}. The Custom Naming Schemes section here will get you started with that:
viewtopic.php?t=4116

e.g.

Code: Select all

E:/Movies/{n} ({y})/{n} ({y}){" [$vf, $kbps, $vc, $ac]"}{'-cd'+pi}{'.'+lang}
:idea: Please read the FAQ and How to Request Help.

AbedlaPaille
Posts: 90
Joined: 12 Apr 2020, 04:02

Re: Plex + filebot: splitted movies issue

Post by AbedlaPaille » 24 Jun 2020, 02:35

The problem with that Rednoah is perfectionism. Because CD1 can be below CD2 in explorer if some of the info differs, like bitrate. That's why we put CD$ before the extra informations.

And i think that's why Plex thinks those are duplicates yeah. I have the same problem. More of a Plex problem than a Filebot one though

User avatar
rednoah
The Source
Posts: 18537
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Plex + filebot: splitted movies issue

Post by rednoah » 24 Jun 2020, 04:44

Well, the Plex standard does not specify extra information like codecs at all, so the placement of CD1/2 is only defined as Name (Year) CD1, which doesn't allow for additional information depending on how you look at it, so someone would have to test what works best.

I would assume that Plex stacking only works if you use clear filename.CD1.mkv style naming where CD1 is at the end, thus making the code easy and the behaviour predictable.
:idea: Please read the FAQ and How to Request Help.

Post Reply