Mojave (clean install) and filebot installation failed

Support for macOS users and the Mac App Store package
Post Reply
exper2123
Posts: 2
Joined: 05 Sep 2018, 22:10

Mojave (clean install) and filebot installation failed

Post by exper2123 » 06 Oct 2018, 17:21

Hi,
I have a new OS mojave on my macbook pro and the installation of filebot.pkg 4.8.2 failed in the end of the install...Do you know why??

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 06 Oct 2018, 17:39

No idea. Does the log say anything?

If you install via console then you might get some interesting console output:
https://raw.githubusercontent.com/fileb ... ler/pkg.sh
:idea: Please read the FAQ and How to Request Help.

emilejacobs
Posts: 2
Joined: 16 Oct 2018, 07:39

Re: Mojave (clean install) and filebot installation failed

Post by emilejacobs » 16 Oct 2018, 07:42

I am experiencing the exact same issue. I tried both UI and terminal install with the same error.

Log below:

Code: Select all

+ VERSION=4.8.2
+ URL=https://get.filebot.net/filebot/FileBot_4.8.2/FileBot_4.8.2.pkg
+ PKG=/var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg
+ APP=/Applications/FileBot.app
+ fetch /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg https://get.filebot.net/filebot/FileBot_4.8.2/FileBot_4.8.2.pkg
+ curl --verbose --fail --location --output /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg --time-cond /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg --retry 5 https://get.filebot.net/filebot/FileBot_4.8.2/FileBot_4.8.2.pkg
Warning: Illegal date format for -z, --time-cond (and not a file name). 
Warning: Disabling time condition. See curl_getdate(3) for valid date syntax.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
  0     0    0     0    0     0      0      0 --:--:-- --:--:-- --:--:--     0*   Trying 104.25.254.17...
* TCP_NODELAY set
* Connected to get.filebot.net (104.25.254.17) port 443 (#0)
* ALPN, offering h2
* ALPN, offering http/1.1
* Cipher selection: ALL:!EXPORT:!EXPORT40:!EXPORT56:!aNULL:!LOW:!RC4:@STRENGTH
* successfully set certificate verify locations:
*   CAfile: /etc/ssl/cert.pem
  CApath: none
* TLSv1.2 (OUT), TLS handshake, Client hello (1):
} [221 bytes data]
* TLSv1.2 (IN), TLS handshake, Server hello (2):
{ [96 bytes data]
* TLSv1.2 (IN), TLS handshake, Certificate (11):
{ [3742 bytes data]
* TLSv1.2 (IN), TLS handshake, Server key exchange (12):
{ [114 bytes data]
* TLSv1.2 (IN), TLS handshake, Server finished (14):
{ [4 bytes data]
* TLSv1.2 (OUT), TLS handshake, Client key exchange (16):
} [37 bytes data]
* TLSv1.2 (OUT), TLS change cipher, Client hello (1):
} [1 bytes data]
* TLSv1.2 (OUT), TLS handshake, Finished (20):
} [16 bytes data]
* TLSv1.2 (IN), TLS change cipher, Client hello (1):
{ [1 bytes data]
* TLSv1.2 (IN), TLS handshake, Finished (20):
{ [16 bytes data]
* SSL connection using TLSv1.2 / ECDHE-ECDSA-CHACHA20-POLY1305
* ALPN, server accepted to use h2
* Server certificate:
*  subject: OU=Domain Control Validated; OU=PositiveSSL Multi-Domain; CN=ssl388286.cloudflaressl.com
*  start date: Sep  3 00:00:00 2018 GMT
*  expire date: Mar 12 23:59:59 2019 GMT
*  subjectAltName: host "get.filebot.net" matched cert's "*.filebot.net"
*  issuer: C=GB; ST=Greater Manchester; L=Salford; O=COMODO CA Limited; CN=COMODO ECC Domain Validation Secure Server CA 2
*  SSL certificate verify ok.
* Using HTTP2, server supports multi-use
* Connection state changed (HTTP/2 confirmed)
* Copying HTTP/2 data in stream buffer to connection buffer after upgrade: len=0
* Using Stream ID: 1 (easy handle 0x7fca6a80ba00)
> GET /filebot/FileBot_4.8.2/FileBot_4.8.2.pkg HTTP/2
> Host: get.filebot.net
> User-Agent: curl/7.54.0
> Accept: */*
> 
* Connection state changed (MAX_CONCURRENT_STREAMS updated)!
  0     0    0     0    0     0      0      0 --:--:--  0:00:02 --:--:--     0< HTTP/2 200 
< date: Tue, 16 Oct 2018 07:34:47 GMT
< content-type: application/octet-stream
< content-length: 101529183
< set-cookie: __cfduid=dc061b89ba6164f4b15c9d27df094f4b61539675285; expires=Wed, 16-Oct-19 07:34:45 GMT; path=/; domain=.filebot.net; HttpOnly; Secure
< last-modified: Wed, 08 Aug 2018 14:39:02 GMT
< etag: "60d365f-572ed78c26e28"
< cf-cache-status: MISS
< expires: Wed, 17 Oct 2018 07:34:46 GMT
< cache-control: public, max-age=86400
< accept-ranges: bytes
< expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
< server: cloudflare
< cf-ray: 46a8d8482de2ac4e-JNB
< 
{ [982 bytes data]
100 96.8M  100 96.8M    0     0   946k      0  0:01:44  0:01:44 --:--:-- 1386k
* Connection #0 to host get.filebot.net left intact
+ verify /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg
+ pkgutil --check-signature /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg
Package "FileBot.pkg":
   Status: signed by a certificate trusted by Mac OS X
   Certificate Chain:
    1. Developer ID Installer: Point Planck Limited (EN9ZYER6WW)
       SHA1 fingerprint: 09 0F BF C4 E5 10 1C FA C0 9E 16 03 5C 6B 81 BA 6D 49 1A 3D
       -----------------------------------------------------------------------------
    2. Developer ID Certification Authority
       SHA1 fingerprint: 3B 16 6C 3B 7D C4 B7 51 C9 FE 2A FA B9 13 56 41 E3 88 E1 86
       -----------------------------------------------------------------------------
    3. Apple Root CA
       SHA1 fingerprint: 61 1E 5B 66 2C 59 3A 08 FF 58 D1 4A E2 24 52 D1 98 DF 6C 60

+ spctl --assess --verbose --ignore-cache --no-cache --type install /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg
/var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg: accepted
source=Developer ID
+ install /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg
+ sudo installer -verbose -package /var/folders/m3/1k1dw5ts3jndp18m_m1s126r0000gn/T/FileBot.pkg -target LocalSystem
Password:
installer: Package name is FileBot 4.8.2
installer: Installing at base path /
installer: Preparing for installation….....
installer: Preparing the disk….....
installer: Preparing FileBot 4.8.2….....
installer: Waiting for other installations to complete….....
installer: Configuring the installation….....
installer: 	
#
installer: Writing files….....
#
installer: Writing files….....
#
installer: Moving items into place….....
installer: Validating packages….....
#
installer: The install failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 16 Oct 2018, 09:13

That is strange indeed. The log doesn't seem to indicate any particular issue. Just says it failed at the end, but no reason is given...

Did you have a previous version of FileBot installed at /Applications/FileBot.app which causes the installer to fail?

Do you get the same failure if you install via Finder by double-clicking the PKG file?
:idea: Please read the FAQ and How to Request Help.

emilejacobs
Posts: 2
Joined: 16 Oct 2018, 07:39

Re: Mojave (clean install) and filebot installation failed

Post by emilejacobs » 17 Oct 2018, 12:59

This is a new install of FileBot (bought a license yesterday).

The exact same error occurs with the install through both Finder and Terminal.

sisbel
Posts: 1
Joined: 17 Oct 2018, 15:22

Re: Mojave (clean install) and filebot installation failed

Post by sisbel » 17 Oct 2018, 15:37

My attempt to install filebot with the "macOS installer: FileBot_4.8.2.pkg" file also failed with the message "The installation failed (The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.)"

Using the "macOS app bundle: FileBot_4.8.2.app.tar.xz" file the installation succeeded without any problem.

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 17 Oct 2018, 16:22

The pkg.sh script works for me on both High Sierra and Mojave.

You can use the app or portable bundle as a workaround, though make sure to install the correct Java 8 / 10 dependencies as well.
:idea: Please read the FAQ and How to Request Help.

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 23 Oct 2018, 03:58

Can anybody with this issue try this and see if there's more logs that tell us why it's failing?
https://apple.stackexchange.com/a/275917/153654
:idea: Please read the FAQ and How to Request Help.

eMeR
Posts: 4
Joined: 20 Nov 2018, 07:56

Re: Mojave (clean install) and filebot installation failed

Post by eMeR » 20 Nov 2018, 08:06

Hello,
long time MAS version owner. A couple of days ago I've decided to buy a stand alone license to support such a great product. Unfortunately I'm unable to install an app and use the license due to installer error similar to one above:

Code: Select all

Nov 20 09:53:01 MBP Installer[23804]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
Nov 20 09:53:01 MBP Installer[23804]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
Nov 20 09:53:01 MBP Installer[23804]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
Nov 20 09:53:09 MBP installd[541]: PackageKit: ----- Begin install -----
Nov 20 09:53:11 MBP installd[541]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "An error occurred while running scripts from the package “FileBot_4.8.2.pkg”." UserInfo={NSFilePath=./postinstall, NSURL=file://localhost/Users/rimas/Downloads/FileBot_4.8.2.pkg#filebot.pkg, PKInstallPackageIdentifier=net.filebot.FileBot.PKG, NSLocalizedDescription=An error occurred while running scripts from the package “FileBot_4.8.2.pkg”.} {
	    NSFilePath = "./postinstall";
	    NSLocalizedDescription = "An error occurred while running scripts from the package \U201cFileBot_4.8.2.pkg\U201d.";
	    NSURL = "file://localhost/Users/rimas/Downloads/FileBot_4.8.2.pkg#filebot.pkg";
	    PKInstallPackageIdentifier = "net.filebot.FileBot.PKG";
	}
Nov 20 09:53:11 MBP Installer[23804]: Install failed: The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.
Nov 20 09:53:11 MBP Installer[23804]: Displaying 'Install Failed' UI.
Nov 20 09:53:11 MBP Installer[23804]: 'Install Failed' UI displayed message:'The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.'.
It fails during packages validation phase: Image

Any help?

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 20 Nov 2018, 08:49

No idea. I can't reproduce the issue on my side. Have you made sure to first uninstall the MAS version? Make sure that /Applications/FileBot.app doesn't already exist for some reason.
:idea: Please read the FAQ and How to Request Help.

eMeR
Posts: 4
Joined: 20 Nov 2018, 07:56

Re: Mojave (clean install) and filebot installation failed

Post by eMeR » 20 Nov 2018, 08:53

I've tried to install it before and after removing the MAS version from Applications. In both cases the installer ends up with the same result:
Image

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 20 Nov 2018, 08:55

The postinstall script contains only one line and can't really fail:

Code: Select all

ln -sf /Applications/FileBot.app/Contents/MacOS/filebot.sh /usr/local/bin/filebot
The log is indeed failing due to postinstall failing, any reason why this might not work on your machine?
:idea: Please read the FAQ and How to Request Help.

eMeR
Posts: 4
Joined: 20 Nov 2018, 07:56

Re: Mojave (clean install) and filebot installation failed

Post by eMeR » 20 Nov 2018, 09:41

There is no bin in local folder in my case - pretty much standard system without any custom 3rd party manually installed CLI (opensource)apps. Might ln be unhappy with that?

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 20 Nov 2018, 10:26

Odd... I guess you could do mkdir /usr/local/bin and then try again.

Code: Select all

mkdir /usr/local/bin
:idea: Please read the FAQ and How to Request Help.

eMeR
Posts: 4
Joined: 20 Nov 2018, 07:56

Re: Mojave (clean install) and filebot installation failed

Post by eMeR » 20 Nov 2018, 12:15

Yep. That helps:
Image

So.. probably your post-installation script should ensure 'bin' directory existence before trying to create a symlink inside it?

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 20 Nov 2018, 12:33

Yep, the next release will do that.
:idea: Please read the FAQ and How to Request Help.

Antidote
Posts: 2
Joined: 17 Feb 2019, 12:01

Re: Mojave (clean install) and filebot installation failed

Post by Antidote » 17 Feb 2019, 12:24

Hi Everybody !

I have a very similar issue than others but as I am not very good in computer software, I don't understand very well of how to proceed. Indeed, my problem is the same than eMeR's problem but it is not for the same software :

I have the licence of this software and it fails during packages validation phase :
Here is the message of error :

Code: Select all

Feb 17 12:52:51 MacBook-Pro-de-Anne Installer[612]: Package Authoring Error: <background> has an unsupported MIME type: image/data
Feb 17 12:52:51 MacBook-Pro-de-Anne Installer[612]: Package Authoring Error: <background_scaling> has an unsupported MIME type: X-NSObject/NSNumber
Feb 17 12:52:51 MacBook-Pro-de-Anne Installer[612]: Package Authoring Error: <background_alignment> has an unsupported MIME type: X-NSObject/NSNumber
Feb 17 12:52:51 MacBook-Pro-de-Anne Installer[612]: Package Authoring Error: <layout-direction> has an unsupported MIME type: X-NSObject/NSNumber
Feb 17 12:55:11 MacBook-Pro-de-Anne Installer[612]: IFJS: *** exception: TypeError: null is not an object (evaluating 'my.target.systemVersion')
Feb 17 12:55:11 MacBook-Pro-de-Anne Installer[612]: IFJS: *** exception: TypeError: null is not an object (evaluating 'my.target.systemVersion')
Feb 17 12:55:11 MacBook-Pro-de-Anne Installer[612]: IFJS: *** exception: TypeError: null is not an object (evaluating 'my.target.systemVersion')
Feb 17 12:55:11 MacBook-Pro-de-Anne Installer[612]: IFJS: *** exception: TypeError: null is not an object (evaluating 'my.target.systemVersion')
Feb 17 12:55:17 MacBook-Pro-de-Anne installd[445]: PackageKit: ----- Begin install -----
Feb 17 12:55:22 MacBook-Pro-de-Anne installd[445]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "Une erreur s’est produite pendant l’exécution des scripts du paquet « CFX_Lite.pkg »." UserInfo={NSFilePath=./postinstall, NSURL=file://localhost/Users/Anne/Documents/CFX_Lite/CFX_Lite.pkg#MAC_CFX_LITE_FULL.pkg, PKInstallPackageIdentifier=com.garritan.CFX.Litefull.pkg, NSLocalizedDescription=Une erreur s’est produite pendant l’exécution des scripts du paquet « CFX_Lite.pkg ».} {
NSFilePath = "./postinstall";
NSLocalizedDescription = "Une erreur s\U2019est produite pendant l\U2019ex\U00e9cution des scripts du paquet \U00ab\U00a0CFX_Lite.pkg\U00a0\U00bb.";
NSURL = "file://localhost/Users/Anne/Documents/CFX_Lite/CFX_Lite.pkg#MAC_CFX_LITE_FULL.pkg";
PKInstallPackageIdentifier = "com.garritan.CFX.Litefull.pkg";
}
Feb 17 12:55:23 MacBook-Pro-de-Anne Installer[612]: Install failed: Le programme d’installation a rencontré une erreur qui a provoqué l’échec de l’installation. Contactez l’éditeur du logiciel pour obtenir de l’aide.
Feb 17 12:55:23 MacBook-Pro-de-Anne Installer[612]: Displaying 'Install Failed' UI.
Feb 17 12:55:23 MacBook-Pro-de-Anne Installer[612]: 'Install Failed' UI displayed message:'Le programme d’installation a rencontré une erreur qui a provoqué l’échec de l’installation. Contactez l’éditeur du logiciel pour obtenir de l’aide.'.

Could you help me please ? I really do not know what to do anymore and I don't understand the solution of rednoah :
rednoah wrote:
20 Nov 2018, 10:26
Odd... I guess you could do mkdir /usr/local/bin and then try again.

Code: Select all

mkdir /usr/local/bin
Thank you so much for your help !!!

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 17 Feb 2019, 12:30

You can try the latest 4.8.5 beta build, which already includes a fix for this particular problem:
viewtopic.php?f=6&t=9535

Here's a direct link for the macOS installer package:
https://get.filebot.net/filebot/FileBot ... _4.8.5.pkg
:idea: Please read the FAQ and How to Request Help.

Antidote
Posts: 2
Joined: 17 Feb 2019, 12:01

Re: Mojave (clean install) and filebot installation failed

Post by Antidote » 17 Feb 2019, 13:24

Thank you for your answer ! Unfortunately, it is not the FileBot I want to install but a music software, a sound bank :-(
But I really hope that the way to resolve the issue is quite the same !

Could you please explain me what did you mean here ? Thank you for your help :-)
rednoah wrote:
20 Nov 2018, 10:26
Odd... I guess you could do mkdir /usr/local/bin and then try again.

Code: Select all

mkdir /usr/local/bin

User avatar
rednoah
The Source
Posts: 15309
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Mojave (clean install) and filebot installation failed

Post by rednoah » 17 Feb 2019, 13:29

Just spend a few minutes on learning how to use the command-line, and it'll all make sense:
https://www.youtube.com/watch?v=IGmfU6QU5dI


:idea: The solution here is a workaround a bug in the FileBot 4.8.2 installer. It's unlikely that the same workaround works some random other installer.
:idea: Please read the FAQ and How to Request Help.

Post Reply

Who is online

Users browsing this forum: No registered users and 0 guests