[MAS] FileBot wont start

Support for macOS users and the Mac App Store package
Post Reply
erasor2010
Posts: 4
Joined: 11 Jan 2021, 18:38

[MAS] FileBot wont start

Post by erasor2010 »

Hi, i have FileBot Purchased via the MAS a long time ago, today it wont start anymore, the icon only jumps a couple of times and then disapears from the dock. I already reinstalled it but that didnt change anything

When installing FileBot via brew on command line its works but i need to purchase a key again, any ideas?
User avatar
rednoah
The Source
Posts: 19341
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot wont start

Post by rednoah »

Uninstall all editions of FileBot that you may have installed, and then exclusively install FileBot via the Mac App Store. You could look into logs, system logs, filebot logs, etc. If it's an issue specific to the Mac App Store, then you may need to talk to Apple Support, though admittedly they're rarely helpful.


:idea: Here are some general App Store limitations that you'll want to be aware of:
viewtopic.php?t=5983
:idea: Please read the FAQ and How to Request Help.
erasor2010
Posts: 4
Joined: 11 Jan 2021, 18:38

Re: FileBot wont start

Post by erasor2010 »

Hi, like i wrote befor, i already removed every editions of filebot and made a clean install from the appstore, that doesnt work.

Where can i find the filebot logs?
User avatar
rednoah
The Source
Posts: 19341
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: FileBot wont start

Post by rednoah »

You may or may not find something helpful here:

Code: Select all

~/Library/Containers/net.filebot.FileBot/Data/Library/Application Support/User Data

:idea: If you have a second Mac, try it there and see if it works.
:idea: Please read the FAQ and How to Request Help.
erasor2010
Posts: 4
Joined: 11 Jan 2021, 18:38

Re: [MAS] FileBot wont start

Post by erasor2010 »

Hier der inhalt der Log Datei

Code: Select all

Jan 12, 2021 10:06:00 AM net.filebot.Main main
WARNING: Error during startup: IOMACAddress
java.lang.IllegalStateException: Receipt Hash: IOMACAddress
	at net.filebot.platform.mac.MASReceipt.verifyHash(Unknown Source)
	at net.filebot.platform.mac.MASReceipt.check(Unknown Source)
	at net.filebot.Main.main(Unknown Source)
Caused by: java.lang.IllegalStateException: IOMACAddress
	at net.filebot.platform.mac.MASReceipt.getGUID(Unknown Source)
User avatar
rednoah
The Source
Posts: 19341
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [MAS] FileBot wont start

Post by rednoah »

No idea. That error message means that you don't have a primary network interface, which makes no sense. Most likely an issue that you will not have with a pristine macOS install, but what's going awry on your machine specifically is hard to tell.
:idea: Please read the FAQ and How to Request Help.
erasor2010
Posts: 4
Joined: 11 Jan 2021, 18:38

Re: [MAS] FileBot wont start

Post by erasor2010 »

i didnt change anything, it just hapens from one day to the other
User avatar
rednoah
The Source
Posts: 19341
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [MAS] FileBot wont start

Post by rednoah »

You could follow this thread for more ideas:
viewtopic.php?t=12066


:!: Unfortunately, using a different Mac, or doing a factory reset on your current Mac, are the only known solutions for these kinds of strange issues.
:idea: Please read the FAQ and How to Request Help.
Post Reply