SingleFile - My misadventures with Filebot and Synology

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
filebottoo
Posts: 1
Joined: 18 May 2020, 17:58

SingleFile - My misadventures with Filebot and Synology

Post by filebottoo » 19 May 2020, 14:01

Hi,

Tried out filebot on my Windows 10 device on a few local music/mp3 files. Good results and purchased lifetime license. Yay!

I am having multiple problems using Filebot on Synology. Currently unusable. Boo!

Background:

25,x00 mp3 files in 2,x00 albums 268GB /volume1/music
on Synology DS218+ DSM 6.2.2 (upgraded to 6.3.2 - more on that later)
Running Logitech Squeezebox Server 8.x on Synology (Music server with database)
Running Bliss HQ 20200423 on Synology (Album Art retriever) - requires JAVA

All running OK - able to reindex music, search music play music, have Bliss (takes around 18hrs) manually query and download and update/rename/imbed art for mp3 files. Can add remove music files via SMB shares from windows, fedora, raspberry pi machines.
have /music and /musictemp directories on Synology

Raspberry Pi 4
First installed Filebot on Raspberry Pi 4 - ultimate outcome -fail
Mounted SMB /music and /musictemp
Imported local on Pi .psm license file and activated
Tried to run Filebot on mounted /music - took 2 hours to load directories and sub-directories
Tried to fetch music data from ID3tags
Spinning yellow balls, 95% Raspberry Pi CPU, and two hours later, nothing
Ran Filebot Raspberry Pi on single local mp3 file and it works ok
Back to my 268GB of files SMB mounted from my Synology NAS
Tried a few times and gave up after a few hours of 90% CPU and fetch stalling - time to run on device with files of interest - Synology
Would be willing to let Filebot run in background for a few days if necessary

SYNOLOGY
Installed Filebot 4.9.1 on Synology using instructions from viewtopic.php?t=1802
Installed filebot, filebot node, node.js, java, MediaInfo, Chromaprint
Tried to import local copy of .psm license file into filebot node - error message something about /fake/fake path????? - an indication of path problems to come? FYI Bliss HQ imported local .psm file for its license OK
Imported .psm file to filebot node from my Windows 10 machine and it worked

Opened Filebot node
loaded source /music and destination /musictemp - took less than 60 seconds to load directories and sub-directories
Tried dry run/copy match
Starts but then "fails"
Ignore system path: /volume1/music/album1name/@eaDir
Ignore system path: /volume1/music/album2name/@eaDir
Ignore system path: /volume1/music/album3name/@eaDir
...
Ignore system path: /volume1/music/album2x00/@eaDir
More than two thousand ignore path entries

See others have Ignore system path: errors viewtopic.php?t=10749
I find it hard to believe permission errors - Squeezebox, Bliss HQ and Raspberry Pi have no problems accessing and manipulating files/directories either locally or SMB mounted.
Bliss running local java and can read/manipulate files and directories

So far unable to use Filebot except on "SINGLEFILES"

It gets worse - Synology automagically updated DSM 6.2.2 to DSM 6.3.2 yesterday
Synology very sluggish and logon to Synology - CPU 80-90%
Message that upgrade has gone OK but FILEBOT NODE needs to be repaired
I delete Filebot, Filebot node and CPU returns to normal. Reinstall filebot and filebot node and try to start Filebot Node - node does not start
Check dependencies - all installed but NODE JS gives confusing information - says available but also installed at the same time - deleted Node.js filebot filebot node and reinstalled
Still no joy, clicking on Filebot node, it will not open/run

So can't even get Filebot node to run now.

Suggestons?

Thanks

User avatar
rednoah
The Source
Posts: 18381
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: SingleFile - My misadventures with Filebot and Synology

Post by rednoah » 19 May 2020, 16:06

1.
Well, so what is the actual error that makes the amc script call fail in the end?

:idea: Ignore: ... is just normal logging that will tell you what files are or are not being selected for processing. @eaDir folders are used by Synology services, and so we'll want to ignore them. You can change the log level if you find verbose logging more confusing than helpful.

:idea: Make sure to click Dry Run instead of Execute for testing.


2.
If FileBot Node doesn't start, then you'll want to look at the log to find out what's going on:
viewtopic.php?f=13&t=11030
:idea: Please read the FAQ and How to Request Help.

Post Reply