Format with {original} not working

Any questions? Need some help?
Post Reply
user1349813
Posts: 2
Joined: 17 Dec 2019, 01:17

Format with {original} not working

Post by user1349813 » 17 Dec 2019, 01:21

I have the following format:

E:/Movies/{ny}/{original}

The folder is created corretly but the filename ends up being just ".mkv" - how do I use the orinal file name?

FileBot 4.8.5

kim
Power User
Posts: 855
Joined: 15 May 2014, 16:17

Re: Format with {original} not working

Post by kim » 17 Dec 2019, 01:35

Code: Select all

{fn}
;)

user1349813
Posts: 2
Joined: 17 Dec 2019, 01:17

Re: Format with {original} not working

Post by user1349813 » 17 Dec 2019, 01:37

Thank you.

Why does https://www.filebot.net/naming.html suggest that {original} is a valid token?

kim
Power User
Posts: 855
Joined: 15 May 2014, 16:17

Re: Format with {original} not working

Post by kim » 17 Dec 2019, 01:41

fn = current filename
original = the "fn" if renamed AND has this data in xattr aka metadata
viewtopic.php?t=324

User avatar
rednoah
The Source
Posts: 17304
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Format with {original} not working

Post by rednoah » 17 Dec 2019, 08:42

user1349813 wrote:
17 Dec 2019, 01:37
Why does https://www.filebot.net/naming.html suggest that {original} is a valid token?
{original} refers to the original filename before any renaming with FileBot, as stored in the net.filebot.filename xattr field when the file was renamed with FileBot for the first time:
viewtopic.php?t=324

:arrow: Hence, on first rename, {original} is always undefined.
:idea: Please read the FAQ and How to Request Help.

Post Reply