Paying customer: Filebot destroyed my files

Any questions? Need some help?
Post Reply
argonavis
Posts: 4
Joined: 29 Jul 2019, 21:53

Paying customer: Filebot destroyed my files

Post by argonavis »

Hi.

I used to have a one year license and run Filebot node on docker, on a NAS.

I completely forgot the NAS and the license conditions for a while. Came back to it with 1TB worth of new files after the ongoing lockdown, and happily ran my usual sorting command.

Which ended up as per the log hereafter.

Fine. I went and purchased a lifetime license, then got ready to re-run the lengthy classification operation...

To find that I just can't find my files. They seem to have disappeared :shock:

Pardon my French but: what gives?

Code: Select all

Whoopsies! --action MOVE requires a valid license.
* Consider using --action TEST
License Error: P8773078 has EXPIRED on 2020-08-03
 ________________________________________________ 
/ Please purchase a FileBot License:             \
\ https://www.filebot.net/purchase.html#docker   /
 ------------------------------------------------ 
      \                             .       .
       \                           / `.   .' " 
        \                  .---.  <    > <    >  .---.
         \                 |    \  \ - ~ ~ - /  /    |
               _____          ..-~             ~-..-~
              |     |   \~~~\.'                    `./~~~/
             ---------   \__/                        \__/
            .'  O    \     /               /       \  " 
           (_____,    `._.'               |         }  \/~~~/
            `----.          /       }     |        /    \__/
                  `-.      |       /      |       /      `. ,~~|
                      ~-.__|      /_ - ~ ^|      /- _      `..-'   
                           |     /        |     /     ~-.     `-. _  _  _
                           |_____|        |_____|         ~ - . _ _ _ _ _>
FileBot requires a valid license. Please run `sudo -H -u root filebot --license *.psm` to install your FileBot license.
Bad License (>_<)

------------------------------------------

[Process error]

🔺 Exit Code: 2

💡 You may evaluate FileBot Node by using [Dry Run] instead of [Execute]
argonavis
Posts: 4
Joined: 29 Jul 2019, 21:53

Re: Paying customer: Filebot destroyed my files

Post by argonavis »

My bad. The file client I am using (Dolphin, KDE) was just not refreshing following the change. I disconnected the network share, re-connected it, cleared these entries from the `.excludes` file, and everything is back to normal.

Thank you!! (sigh of relief).

(And feel free to delete this thread).
User avatar
rednoah
The Source
Posts: 19435
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Paying customer: Filebot destroyed my files

Post by rednoah »

Always use Dry Run (i.e. --action TEST) first, before processing files for real, or at least use --action hardlink to preserve the original file structure, just in case. Something will go wrong sooner or later. ;)



:idea: Use Synology DSM or login via SSH to get authoritative answers. The file listings you see remotely from your Desktop PC may be deceiving. In this case, it's likely server-side caching. Since you're using generic filebot within a docker container, it won't be able to call synoindex on the host NAS after processing files.
:idea: Please read the FAQ and How to Request Help.
Post Reply