Automation broke after brew update

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
mikejandreau
Posts: 21
Joined: 07 Jun 2017, 16:50

Automation broke after brew update

Post by mikejandreau » 11 Jan 2019, 13:02

I ran a

Code: Select all

brew update
the other day to update some of my packages, and something that updated caused my Filebot automation to break.

I'm running a postprocess.sh script from Transmission:

Code: Select all

/usr/local/bin/filebot -script fn:amc --output "$CONFIG_OUTPUT" --action move --conflict skip -non-strict --log-file amc.log --def clean=y unsorted=y music=y artwork=n excludeList=".excludes" ut_dir="$ARG_PATH" ut_kind="multi" ut_title="$ARG_NAME" ut_label="$ARG_LABEL"
That's been working for ages, as is.

Once I noticed it failing, I ran it by hand on a file I'd just downloaded, as:

Code: Select all

filebot -script fn:amc --output "/" --action move --conflict skip -non-strict --log-file amc.log --def clean=y unsorted=y music=y artwork=n excludeList=".excludes" ut_dir="/" ut_kind="multi" ut_title="Vikings"
My amc.log error is:

Code: Select all

Alfred$ filebot -script fn:amc --output "/" --action move --conflict skip -non-strict --log-file amc.log --def clean=y unsorted=y music=y artwork=n excludeList=".excludes" ut_dir="/" ut_kind="multi" ut_title="Viking Games"
Locking /Users/Alfred/.filebot/logs/amc.log
BUG! exception in phase 'semantic analysis' in source unit 'Script1.groovy' null
BUG! exception in phase 'semantic analysis' in source unit 'Script1.groovy' null
	at net.filebot.cli.ScriptShell.evaluate(ScriptShell.java:64)
	at net.filebot.cli.ScriptShell.runScript(ScriptShell.java:74)
	at net.filebot.cli.ArgumentProcessor.runScript(ArgumentProcessor.java:154)
	at net.filebot.cli.ArgumentProcessor.run(ArgumentProcessor.java:36)
	at net.filebot.Main.main(Main.java:131)
Caused by: java.lang.UnsupportedOperationException
	at groovyjarjarasm.asm.ClassVisitor.visitNestMemberExperimental(ClassVisitor.java:248)
	at groovyjarjarasm.asm.ClassReader.accept(ClassReader.java:651)
	at groovyjarjarasm.asm.ClassReader.accept(ClassReader.java:391)
	... 5 more

Failure (°_°)
When I try to run

Code: Select all

filebot -script fn:sysinfo
, I get the same error.

I thought it might be because the brew update got me Java 11 (which it did), so I uninstalled that and am back on what I think is Java 8:

Code: Select all

Alfred$ java -version
java version "1.8.0_131"
Java(TM) SE Runtime Environment (build 1.8.0_131-b11)
Java HotSpot(TM) 64-Bit Server VM (build 25.131-b11, mixed mode)
If I try to install java10:

Code: Select all

Alfred$  brew cask install java10
Warning: Cask 'java10' is already installed.

To re-install java10, run:
  brew cask reinstall java10
However, when I try to reinstall java10:

Code: Select all

Alfred$  brew cask reinstall java10
==> Caveats
This Cask makes minor modifications to the JRE to prevent issues with
packaged applications, as discussed here:

  https://bugs.eclipse.org/bugs/show_bug.cgi?id=411361

If your Java application still asks for JRE installation, you might need
to reboot or logout/login.

Installing java10 means you have AGREED to the license at
  https://www.oracle.com/technetwork/java/javase/terms/license/index.html

==> Satisfying dependencies
==> Downloading http://download.oracle.com/otn-pub/java/jdk/10.0.2+13/19aef61b38124481863b1413dce1855f/jdk-10.0.2_osx-x64_bin.
==> Downloading from https://download.oracle.com/otn-pub/java/jdk/10.0.2+13/19aef61b38124481863b1413dce1855f/jdk-10.0.2_osx-x6

curl: (22) The requested URL returned error: 404 Not Found
Error: Download failed on Cask 'java10' with message: Download failed: http://download.oracle.com/otn-pub/java/jdk/10.0.2+13/19aef61b38124481863b1413dce1855f/jdk-10.0.2_osx-x64_bin.dmg
I also tried redownloading the .pkg of the Filebot CLI, which didn't seem to fix the issue (though I didn't expect it to, given this seems to be a java issue).

Any help is greatly appreciated.

mikejandreau
Posts: 21
Joined: 07 Jun 2017, 16:50

Re: Automation broke after brew update

Post by mikejandreau » 11 Jan 2019, 13:07

Fixed it.

I must not have fully uninstalled Java11.

For anyone else having the issue on MacOS, go to /Library/Java/JavaVirtualMachines and delete Java11 from there, which should force you back down to Java10 and life will go back to normal.

User avatar
rednoah
The Source
Posts: 16101
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Automation broke after brew update

Post by rednoah » 11 Jan 2019, 14:51

Best to just go with PKG installer for now. That one bundles the JRE internally and thus doesn't need nor care about the system-wide JRE:
viewtopic.php?f=4&t=2049

Once 4.8.5 is released, then the brew cask package should work out of the box again.
:idea: Please read the FAQ and How to Request Help.

Bottrill245
Posts: 1
Joined: 24 Apr 2019, 09:07

Re: Automation broke after brew update

Post by Bottrill245 » 24 Apr 2019, 09:14

This is new behaviour that has been added and executee without notifying me and severely hampered my system and my workflow, and undermines something I understood about homebrew.

User avatar
rednoah
The Source
Posts: 16101
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Automation broke after brew update

Post by rednoah » 24 Apr 2019, 09:34

Newer versions of FileBot no longer have any dependencies, so this particular issue effectively can't happen any more.
:idea: Please read the FAQ and How to Request Help.

Post Reply