[QNAP] FileBot Node can not find java

Support for Synology NAS, QNAP NAS and other Embedded Linux systems
Post Reply
savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

[QNAP] FileBot Node can not find java

Post by savonarola » 04 Nov 2019, 17:07

I have installed FileBot and FileBot Node (licensed) on my QNAP with QTS 4.4.1.1086 (latest firmware available).
Node.js is installed with version 8.9.4.0.1 (from QNAP app center).
Java is installed woth version JRE 8.151.2.1 (from QNAP app center).

Installation is ok for both and FileBot CLI works like a charm.

FileBot Node app start on QTS but doesn't work giving me the following message on the conle window frame:

Code: Select all

$ filebot -version
/usr/bin/filebot: line 37: java: command not found
Also other tasks, for example the license installation, fail because java command can not be found.

Any help?

Thanks.

User avatar
rednoah
The Source
Posts: 16964
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [QNAP] FileBot Node can not find java

Post by rednoah » 04 Nov 2019, 18:55

1.
Please use the Java Installer package from the FileBot repository:
https://www.filebot.net/linux/qnap.html


:!: QNAP packages for 3rd party products provided by QNAP are usually outdated and badly maintained, and thus may not work well.



2.
Once you're on Java 13, you will run into this issue here, which can be resolved by installing the latest beta of FileBot:
viewtopic.php?f=13&t=11099
:idea: Please read the FAQ and How to Request Help.

savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

Re: [QNAP] FileBot Node can not find java

Post by savonarola » 05 Nov 2019, 10:56

First do I need to uninstall the official QNAP Java package from app center?

User avatar
rednoah
The Source
Posts: 16964
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [QNAP] FileBot Node can not find java

Post by rednoah » 05 Nov 2019, 11:30

Likely irrelevant. You can have both installed. But having only one of them installed might make troubleshooting easier if you do run into problems.
:idea: Please read the FAQ and How to Request Help.

savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

Re: [QNAP] FileBot Node can not find java

Post by savonarola » 05 Nov 2019, 12:16

Tried to install java-installer. The package installation is ok but after the start my QNAP report an error telling me to see install-java.log:

Code: Select all

# cat install-java.log
Warning: Illegal date format for -z, --timecond (and not a file name).
Warning: Disabling time condition. See curl_getdate(3) for valid date syntax.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   862  100   862    0     0   2809      0 --:--:-- --:--:-- --:--:--  3045
cmp: EOF on /share/CACHEDEV1_DATA/.qpkg/java-installer/get-java.sh.asc
[Tue Nov  5 13:09:19 CET 2019: AUTO UPDATE
Warning: Illegal date format for -z, --timecond (and not a file name).
Warning: Disabling time condition. See curl_getdate(3) for valid date syntax.
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  4253  100  4253    0     0  14831      0 --:--:-- --:--:-- --:--:-- 14975
gpg: keyring `/share/CACHEDEV1_DATA/.qpkg/java-installer/.gnupg/pubring.gpg' created
gpg: Signature made Sat Nov  2 07:16:26 2019 CET using RSA key ID 7C3C6A71
gpg: /share/CACHEDEV1_DATA/.qpkg/java-installer/.gnupg/trustdb.gpg: trustdb created
gpg: key 7C3C6A71 marked as ultimately trusted
gpg: checking the trustdb
gpg: 3 marginal(s) needed, 1 complete(s) needed, PGP trust model
gpg: depth: 0  valid:   1  signed:   0  trust: 0-, 0q, 0n, 0m, 0f, 1u
gpg: Good signature from "Reinhard Pointner <[email protected]>"
[GNUPG:] TRUST_ULTIMATE
Download https://download.bell-sw.com/java/13.0.1/bellsoft-jdk13.0.1-linux-arm32-vfp-hflt.tar.gz
egrep: invalid option -- 'o'
BusyBox v1.01 (2019.10.24-18:37+0000) multi-call binary

No help available.

Expected SHA256 checksum: e3764deca0f72bab9737c16b4a3655040ab4c51ecfad837179c4b8e232d64381
Actual SHA256 checksum:
ERROR: SHA256 checksum mismatch
Tue Nov  5 13:09:35 CET 2019: Add environment variables to /etc/profile

savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

Re: [QNAP] FileBot Node can not find java

Post by savonarola » 05 Nov 2019, 13:58

I think there are issues with egrep and curl aliases or something like these... Is java-installer compatible also with QNAP devices or only with Synology ones?

I am trying to make some debug of the installation-service and get-java scripts but it's not so simple...

savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

Re: [QNAP] FileBot Node can not find java

Post by savonarola » 05 Nov 2019, 15:53

Ok. I have downloaded get-java.sh from https://github.com/rednoah/java-installer and modified it in the part of egrep command.

JDK 13 installed and now filebot-node works.

User avatar
rednoah
The Source
Posts: 16964
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: [QNAP] FileBot Node can not find java

Post by rednoah » 05 Nov 2019, 17:47

What does uname -a say? What QNAP NAS model do you have?


egrep -o works for me... But my QNAP QTS seems to be based on a newer BusyBox release:

Code: Select all

egrep
BusyBox v1.24.1 (2019-10-25 02:44:00 CST) multi-call binary.

No help available.


EDIT:

Does awk work on super-outdated BusyBox?

Code: Select all

echo 'PRINT THIS' | awk '{print $NF}'
THIS
:idea: Please read the FAQ and How to Request Help.

savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

Re: [QNAP] FileBot Node can not find java

Post by savonarola » 06 Nov 2019, 10:30

rednoah wrote:
05 Nov 2019, 17:47
What does uname -a say? What QNAP NAS model do you have?

Code: Select all

Linux NAS 4.2.8 #2 SMP Fri Oct 25 05:27:36 CST 2019 armv7l unknown
rednoah wrote:
05 Nov 2019, 17:47
egrep -o works for me... But my QNAP QTS seems to be based on a newer BusyBox release:

Code: Select all

egrep
BusyBox v1.24.1 (2019-10-25 02:44:00 CST) multi-call binary.

No help available.
For me no because I don't have an alias for "egrep" but also if I create one the script doesn't work.

rednoah wrote:
05 Nov 2019, 17:47
Does awk work on super-outdated BusyBox?

Code: Select all

echo 'PRINT THIS' | awk '{print $NF}'
THIS
Yes it works for me.

savonarola
Posts: 8
Joined: 06 Mar 2018, 11:48

Re: [QNAP] FileBot Node can not find java

Post by savonarola » 06 Nov 2019, 11:04

rednoah wrote:
05 Nov 2019, 17:47
What QNAP NAS model do you have?
QNAP TS-231P with firmware 4.4.1.1101
(BusyBox v1.01 (2019.10.24-18:37+0000) multi-call binary)

Post Reply