"Unable to establish loopback connection" Windows Store v.5.0.3.0

Support for Windows users
Post Reply
BackdoorJesus
Posts: 2
Joined: 24 May 2023, 20:41

"Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by BackdoorJesus »

Hi team,

I am experiencing an error when attempting to fetch data for TV show renaming. My application is the Windows Store app, just updated, it seems, yesterday 5/23/2023.

I am wondering if this is perhaps a bug since this was just updated on my system (Windows 11 x64) or if it a configuration on my end I need to take care of. The program has worked pretty consistently for me for some years now.

This is the error log from today:

Code: Select all


May 24, 2023 1:34:16 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
May 24, 2023 1:34:19 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
May 24, 2023 1:34:22 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
May 24, 2023 1:51:41 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.themoviedb.org/3/search/tv: Unable to establish loopback connection
May 24, 2023 1:51:41 PM net.filebot.ui.rename.RenamePanel$AutoCompleteAction lambda$start$7
WARNING: Unable to establish loopback connection
java.util.concurrent.ExecutionException: java.util.concurrent.ExecutionException: java.io.UncheckedIOException: java.io.IOException: Unable to establish loopback connection
	at net.filebot.util.ui.SwingUI$SwingLambda.done(Unknown Source)
Caused by: java.util.concurrent.ExecutionException: java.io.UncheckedIOException: java.io.IOException: Unable to establish loopback connection
	at net.filebot.Parallelism.map(Unknown Source)
	at net.filebot.ui.rename.EpisodeListMatcher.matchVideoFiles(Unknown Source)
	at net.filebot.ui.rename.EpisodeListMatcher.match(Unknown Source)
	at net.filebot.ui.rename.RenamePanel$AutoCompleteAction.lambda$start$3(Unknown Source)
	at net.filebot.util.ui.SwingUI$SwingLambda.doInBackground(Unknown Source)
Caused by: java.io.UncheckedIOException: java.io.IOException: Unable to establish loopback connection
	at net.filebot.web.WebRequest.httpClient(Unknown Source)
	at net.filebot.web.WebRequest.httpRequestV2(Unknown Source)
	at net.filebot.web.WebRequest.fetch(Unknown Source)
	at net.filebot.CachedResource.lambda$fetchIfNoneMatch$18(Unknown Source)
	at net.filebot.CachedResource.lambda$get$0(Unknown Source)
	at net.filebot.CachedResource.retry(Unknown Source)
	at net.filebot.CachedResource.lambda$get$1(Unknown Source)
	at net.filebot.Cache.computeIf(Unknown Source)
	at net.filebot.Cache$ConcurrentCache.lambda$computeIf$1(Unknown Source)
	at net.filebot.Cache$ConcurrentCache.withLock(Unknown Source)
	at net.filebot.Cache$ConcurrentCache.computeIf(Unknown Source)
	at net.filebot.CachedResource.get(Unknown Source)
	at net.filebot.web.TMDbCore.request(Unknown Source)
	at net.filebot.web.TMDbTVClient.search(Unknown Source)
	at net.filebot.web.TMDbTVClient.fetchSearchResult(Unknown Source)
	at net.filebot.WebServices$TMDbTVClient.fetchSearchResult(Unknown Source)
	at net.filebot.web.AbstractEpisodeListProvider.lambda$search$0(Unknown Source)
	at net.filebot.Cache.computeIf(Unknown Source)
	at net.filebot.Cache$TypedCache.computeIf(Unknown Source)
	at net.filebot.Cache.computeIfAbsent(Unknown Source)
	at net.filebot.Cache$TypedCache.computeIfAbsent(Unknown Source)
	at net.filebot.web.AbstractEpisodeListProvider.search(Unknown Source)
	at net.filebot.ui.rename.EpisodeListMatcher.lookupSeries(Unknown Source)
	at net.filebot.ui.rename.EpisodeListMatcher.fetchEpisodeSet(Unknown Source)
	at net.filebot.ui.rename.EpisodeListMatcher.matchEpisodeSet(Unknown Source)
	at net.filebot.ui.rename.EpisodeListMatcher.lambda$matchVideoFiles$7(Unknown Source)
	at net.filebot.Parallelism$Task.call(Unknown Source)
	at net.filebot.Parallelism$Task.call(Unknown Source)
Caused by: java.io.IOException: Unable to establish loopback connection
	... 28 more
Caused by: java.net.SocketException: Invalid argument: connect
	... 28 more

May 24, 2023 1:54:36 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
May 24, 2023 1:54:47 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
May 24, 2023 1:54:50 PM net.filebot.CachedResource lambda$get$1
SEVERE: Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
Please just LMK if there is something I need to do on my end, or if I can provide any other/better info to help you resolve this with me.
User avatar
rednoah
The Source
Posts: 23074
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by rednoah »

:arrow: Likely duplicate of Unable to establish loopback connection.


:arrow: Press WIN+R and then run the following command to configure FileBot to use the legacy HTTP/1 API:

Code: Select all

setx FILEBOT_OPTS "-Dnet.filebot.web.WebRequest.v1=true"
:idea: Please read the FAQ and How to Request Help.
BackdoorJesus
Posts: 2
Joined: 24 May 2023, 20:41

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by BackdoorJesus »

Thank you rednoah that command got me going again. Admittedly I looked at the other thread but I missed/overlooked that solution. Thanks again for pointing me in the right direction
BBear309
Posts: 3
Joined: 28 Jan 2017, 17:53

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by BBear309 »

I had this issue just today also. Thanks for the command. Filebot is working for me again!
ZeroByDivide
Posts: 170
Joined: 16 Dec 2014, 01:39

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by ZeroByDivide »

Yep running into the same issue as well with the recent update to the store version.. The only thing that worked was going in and making a system.properties file with the following information in it:

Code: Select all

#FileBot System Properties
net.filebot.web.WebRequest.v1=true
java.net.preferIPv4Stack=true
also @rednoah did something with ID change as of recent as well? Getting this error as well:

Code: Select all

Undefined Variable: java.lang.NullPointerException: Cannot get property 'id' on null object at __script_5d54a20a201c818526556962e6e476a6_506::run in net.filebot.GroovyEngine::eval in net.filebot.cli.ScriptShell::evaluate
java.lang.NullPointerException: Cannot get property 'id' on null object
	at __script_5d54a20a201c818526556962e6e476a6_506.run(__script_5d54a20a201c818526556962e6e476a6_506:13)
	at net.filebot.GroovyEngine.eval(Unknown Source)
	at net.filebot.cli.ScriptShell.evaluate(Unknown Source)
	at net.filebot.cli.ScriptShell.runScript(Unknown Source)
	at net.filebot.cli.ArgumentProcessor.runScript(Unknown Source)
	at net.filebot.cli.ArgumentProcessor.run(Unknown Source)
	at net.filebot.cli.ExecCommand.execute(Unknown Source)
	at net.filebot.cli.CmdlineOperations.applyPostProcess(Unknown Source)
	at net.filebot.cli.CmdlineOperations.renameAll(Unknown Source)
	at net.filebot.cli.CmdlineOperations.renameSeries(Unknown Source)
	at net.filebot.cli.CmdlineOperations.rename(Unknown Source)
	at net.filebot.cli.ScriptShellBaseClass.rename(Unknown Source)
	at __script_aabde465e3413fd214d849b6b09bd0bc_60b0$_run_closure67.doCall(__script_aabde465e3413fd214d849b6b09bd0bc_60b0:429)
	at __script_aabde465e3413fd214d849b6b09bd0bc_60b0.run(__script_aabde465e3413fd214d849b6b09bd0bc_60b0:416)
	at net.filebot.GroovyEngine.eval(Unknown Source)
	at net.filebot.cli.ScriptShell.evaluate(Unknown Source)
	at net.filebot.cli.ScriptShell.runScript(Unknown Source)
	at net.filebot.cli.ArgumentProcessor.runScript(Unknown Source)
	at net.filebot.cli.ArgumentProcessor.run(Unknown Source)
	at net.filebot.Main.main(Unknown Source)

Error (o_O)
User avatar
rednoah
The Source
Posts: 23074
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by rednoah »

ZeroByDivide wrote: 15 Jun 2023, 20:07 did something with ID change as of recent as well? Getting this error as well:
What is your code? Custom format? Custom script? What ID? Context? :arrow: Please create a new topic for this new topic.
:idea: Please read the FAQ and How to Request Help.
ZeroByDivide
Posts: 170
Joined: 16 Dec 2014, 01:39

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by ZeroByDivide »

rednoah wrote: 15 Jun 2023, 20:25
ZeroByDivide wrote: 15 Jun 2023, 20:07 did something with ID change as of recent as well? Getting this error as well:
What is your code? Custom format? Custom script? What ID? Context? :arrow: Please create a new topic for this new topic.
has been done viewtopic.php?t=13772
julesverne
Posts: 2
Joined: 17 Jul 2023, 06:09

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by julesverne »

I've tried both the system.properties and the setx fixes but still getting the can't establish loopback connection error.

Console Output: Select all

Failed to fetch resource: https://api.filebot.net/9760/script/fn.jar.xz: Unable to establish loopback connection
Unable to establish loopback connection
java.io.UncheckedIOException: java.io.IOException: Unable to establish loopback connection
        at net.filebot.web.WebRequest.httpClient(Unknown Source)
        at net.filebot.web.WebRequest.httpRequestV2(Unknown Source)
        at net.filebot.web.WebRequest.fetch(Unknown Source)
        at net.filebot.CachedResource.lambda$fetchIfModified$13(Unknown Source)
        at net.filebot.CachedResource.lambda$get$0(Unknown Source)
        at net.filebot.CachedResource.retry(Unknown Source)
        at net.filebot.CachedResource.lambda$get$1(Unknown Source)
        at net.filebot.Cache.computeIf(Unknown Source)
        at net.filebot.CachedResource.get(Unknown Source)
        at net.filebot.Resource$Memoized.get(Unknown Source)
        at net.filebot.cli.ScriptBundle.open(Unknown Source)
        at net.filebot.cli.ScriptBundle.getScript(Unknown Source)
        at net.filebot.cli.ScriptShell.runScript(Unknown Source)
        at net.filebot.cli.ArgumentProcessor.runScript(Unknown Source)
        at net.filebot.cli.ArgumentProcessor.run(Unknown Source)
        at net.filebot.Main.main(Unknown Source)
Caused by: java.io.IOException: Unable to establish loopback connection
        ... 16 more
Caused by: java.net.SocketException: Invalid argument: connect
        ... 16 more

Error (o_O)
User avatar
rednoah
The Source
Posts: 23074
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by rednoah »

:!: net.filebot.web.WebRequest.v1=true is not set according to the console output:

Error: Select all

at net.filebot.web.WebRequest.httpRequestV2(Unknown Source)
** httpRequestV2 means that FileBot is using the HTTP/2 implementation


:?: How exactly did you set net.filebot.web.WebRequest.v1=true? Please include screenshots so that we can see what you can see.
:?: Where did you create your system.properties file and what is the file content?
:?: What is the value of your FILEBOT_OPTS environment variable?
:idea: Please read the FAQ and How to Request Help.
julesverne
Posts: 2
Joined: 17 Jul 2023, 06:09

Re: "Unable to establish loopback connection" Windows Store v.5.0.3.0

Post by julesverne »

I put the commands in C:\Users\<username>\AppData\Local\Packages\PointPlanck.FileBot_49ex9gnthnt12\LocalCache\Roaming\FileBot\system.properties. The file is definitely there; I didn't put the comments starting with #, assuming they were not required. Oddly, setx didn't set the variable (at least it's not there when I do set<enter>". It worked using just set and starting filebot from the command line.

EDIT: well, whaddayaknow? it's working now. All I did was added the comment line.
Post Reply