Updating 4.9.3 to 5.1.0 and license not transfered

Any questions? Need some help?
Post Reply
Arkodark
Posts: 3
Joined: 31 Aug 2023, 13:45

Updating 4.9.3 to 5.1.0 and license not transfered

Post by Arkodark »

Hey there :)

I've been buying a licence every year since 2020 and I haven't updated the software since 4.9.3.
Today I wanted to update (to the latest version 5.1.0) but they're asking me for the licence. So I got it back in my confirmation email, but it tells me that my key isn't valid, even though I renewed it in July and version 4.9.3 is working fine.

What's more, I had edited my presets and none of them are transferred to the updated version.

This poses real problems: you pay for a licence and every time you update, you have to reconfigure everything? Was it me who didn't follow the correct process, or is this a problem that needs to be fixed?

Thank you for your help :)
User avatar
rednoah
The Source
Posts: 23150
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Updating 4.9.3 to 5.1.0 and license not transfered

Post by rednoah »

What OS are you using? Windows? How did you install / update FileBot? MSI installer?


:idea: Your user data (including license information) is stored in the application data folder (i.e. %APPDATA%\FileBot assuming a standard Windows install) and any version of FileBot uses the same application data folder, and so all your user data will carry over by default if you update FileBot. If FileBot can't remember your settings, then that would suggest that the application data folder was deleted. That would be most unusual. The MSI installer / uninstaller does not delete your user data.


:?: What does the error message say exactly when FileBot does not accept your license key? (you can click on the error message to copy & paste the error message)


:idea: System Information would answer various questions. Please read How to Request Help for details.
:idea: Please read the FAQ and How to Request Help.
Arkodark
Posts: 3
Joined: 31 Aug 2023, 13:45

Re: Updating 4.9.3 to 5.1.0 and license not transfered

Post by Arkodark »

Hey rednoah, thank you for your quick answer :)
I'm on Windows 10 and I used the msi installer (64-bits) to update FileBot (4.9.3 to 5.1.0)
User avatar
rednoah
The Source
Posts: 23150
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Updating 4.9.3 to 5.1.0 and license not transfered

Post by rednoah »

Then your user data is in %APPDATA%\FileBot. You can check that folder and confirm your user data for yourself. You can downgrade / upgrade and confirm that your user data is not changed or deleted by checking that folder. Your settings are notably also stored in the Windows Registry.

:idea: If all your user data is lost, then that means both %APPDATA%\FileBot folder and the HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft registry keys were deleted somehow by something. That would be most unusual. Definitely not something that FileBot does. But hard to say what might be the cause, since it's your machine and you could be doing or running anything. My first random guess would be some "cleaner" tool that deletes %APPDATA% folders and registry entries. Could be running as different users that have different %APP_DATA% folders. Could be switching from Portable ZIP (which has its own portable app data folder) to MSI installer edition. Could be something else entirely. What is the reason in your case? I don't know. Only you can find it. I'd be very curious to know though.
:idea: Please read the FAQ and How to Request Help.
Arkodark
Posts: 3
Joined: 31 Aug 2023, 13:45

Re: Updating 4.9.3 to 5.1.0 and license not transfered

Post by Arkodark »

I didn't use any cleaner, my configuration didn't change between when I was using version 4.9.3 and when I installed the new version with the msi installer. In fact, I started FileBot 4.9.3 and a popup asked me to update. I'd refused to do so until then because I was wondering whether the presets I'd saved would transfer to the new version, but this time I accepted and it took me to the site, I downloaded the latest version and installed it while 4.9.3 was still open.

It's not too much of a problem with the presets, I'll record them again, but the invalid key is more of a problem, I can't use version 5.1.0 because FileBot asks me for a valid key.

I checked the FileBot folder in AppData, and there's not much there: a cache folder (which itself contains a "0" folder with some .data and .index files), a logs folder containing the error log for my invalid key, an empty tmp folder and an xml file for the preferences (which only contains the preset I'd saved to test whether it worked).

The registry key HKEY_LOCAL_MACHINE\SOFTWARE\JavaSoft does exist, but I'm unable to understand its contents.

What do I have to do to get my key accepted on the latest version?
User avatar
rednoah
The Source
Posts: 23150
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: Updating 4.9.3 to 5.1.0 and license not transfered

Post by rednoah »

:?: What does the error message say exactly when FileBot does not accept your license key? (you can click on the error message to copy & paste the error message)


:idea: There's nothing you need to do. The same key will work with any version of FileBot just the same. If there's an issue for some unknown reason, then I'll need to see the logs which will include your license key so make sure to PM me instead of posting it publically.






EDIT:

I have installed FileBot_4.9.3_x64.msi, then created some Presets, then installed FileBot_5.1.0_x64.msi and was unable to reproduce the "application data folder lost" issue. The 5.1.0 installer notably forced me to quit the currently running 4.9.3 instance. The Presets created in the old version were available in the new version.
:idea: Please read the FAQ and How to Request Help.
Post Reply