filebot not putting in bindings for VF, VF, AC,AF,etc

Running FileBot from the console, Groovy / FileBot scripting, shell scripts, etc
Post Reply
nzdreamer55
Posts: 147
Joined: 20 Jul 2012, 23:25

filebot not putting in bindings for VF, VF, AC,AF,etc

Post by nzdreamer55 » 25 Dec 2018, 21:06

Hello everyone. Just got filebot up and running on my virtual box. Here is what I am using

FileBot 4.8.2 (r5789) / OpenJDK Runtime Environment 1.8.0_191 / Linux 4.15.0-43-generic (amd64)

I have been using the AMC script for some time with the following settings

Code: Select all

filebot -script fn:amc "/media/sf_Series.Pool/2Sort" --def "unsortedFormat=/media/sf_Om/Unsorted/{fn}.{ext}" --def "seriesFormat=/media/sf_Series.Pool/1Finished/{n.replaceFirst(/^(?i)(The|A|An)\s(.+)/, /\$2, \$1/)}/{episode.special ? 'Special' : 'Season '+s.pad(2)}/{n}.{s00e00}{'.'+fn.match(/(?i:proper)/).toLowerCase().upperInitial()}{'.'+fn.match(/(?i:repack)/).toLowerCase().upperInitial()}{'.'+[vf]}{'.'+[vc]}{'.'+[ac]}{'.'+[af]}{'.'+[source]}{'.'+[group]}.{t}" -r --log-file "/home/linux/log/filebot.TV.log" --action copy --conflict auto -non-strict --def backdrops=y --def subtitles=en --def artwork=y --def clean=y --def ut_label=tv --def excludeList="/home/linux/log/exclude/filebot.input.tv"
In the past my files have come out like this

Childrens Hospital.S05E04.[720p].[x264].[AC3].[6ch].[HDTV].Country Weekend

But now I am only getting a couple of things

Bob's Burgers.S03E18.[HDTV].It Snakes a Village

I am getting this error

Failed to set xattr: FileSystemException: /media/sf_Series.Pool/1Finished/Big Bang Theory, The/Season 11/The Big Bang Theory.S11E14.[REMUX].The Separation Triangulation.mkv: Error writing extended attribute 'net.filebot.metadata': Operation not supported

Do I need to install another program? Do I need to use a different Java?

Thank you very much.

nzdreamer55
Posts: 147
Joined: 20 Jul 2012, 23:25

Re: filebot not putting in bindings for VF, VF, AC,AF,etc

Post by nzdreamer55 » 26 Dec 2018, 01:25

One more thing.

Code: Select all

[email protected]:~/Scripts$ filebot -script fn:sysinfo
FileBot 4.8.2 (r5789)
JNA Native: 5.2.2
MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so: Unable to load library 'mediainfo': Native library (linux-x86-64/libmediainfo.so) not found in resource path ([file:/home/linux/filebot-portable/jar/filebot.jar])
7-Zip-JBinding: 9.20
Chromaprint: java.io.IOException: Cannot run program "fpcalc": error=2, No such file or directory
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2018-11-29 (r539)
Groovy: 2.5.1
JRE: OpenJDK Runtime Environment 1.8.0_191
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 1 Core / 955 MB Max Memory / 16 MB Used Memory
OS: Linux (amd64)
HW: Linux linux 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
DATA: /home/linux/filebot-portable/data/linux
Package: TAR
License: FileBot License PX6482836 (Valid-Until: 2068-12-16)
Done ヾ(@⌒ー⌒@)ノ
It seems like libmediainfo.so isn't in the correct place.

User avatar
rednoah
The Source
Posts: 16585
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: filebot not putting in bindings for VF, VF, AC,AF,etc

Post by rednoah » 26 Dec 2018, 08:43

Here's the core of the problem. libmediainfo.so is not working:

Code: Select all

MediaInfo: net.filebot.mediainfo.MediaInfoException: Unable to load amd64 (64-bit) native library libmediainfo.so: Unable to load library 'mediainfo': Native library (linux-x86-64/libmediainfo.so) not found in resource path ([file:/home/linux/filebot-portable/jar/filebot.jar])
libmediainfo.so for amd64 should be included in the portable package. No idea why it's no working. Maybe it's not binary compatible with your version of Ubuntu? Are you using the latest? Maybe it works with 18.04 but not 18.10?

You can probably fix the problem by replacing libmediainfo.so with a compatible binary, maybe and older or newer version will do.

You can also try the new universal package which integrates with existing packages instead of bundling (possibly incompatible) binaries:
viewtopic.php?t=9535
:idea: Please read the FAQ and How to Request Help.

nzdreamer55
Posts: 147
Joined: 20 Jul 2012, 23:25

Re: filebot not putting in bindings for VF, VF, AC,AF,etc

Post by nzdreamer55 » 28 Dec 2018, 15:24

Thank you for the help. Right now File bot is located in a folder called filebot-portable. Is this correct for Ubuntu? I am using 18.04 LTR.

I find that libmediainfo.so is located at home/filebot-portable/lib/Linux-x86_64. Is this also correct?

So If this all is correct, then all I should have to do is get a different libmediainfo.so (older or newer) and replace it. Does this sound correct?

Thanks again.

User avatar
rednoah
The Source
Posts: 16585
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: filebot not putting in bindings for VF, VF, AC,AF,etc

Post by rednoah » 29 Dec 2018, 05:37

rednoah wrote:
26 Dec 2018, 08:43
You can also try the new universal package which integrates with existing packages instead of bundling (possibly incompatible) binaries:
viewtopic.php?t=9535
I'd go with this. On 18.04 LTS you'll want to use the new universal-jdk8.deb package.
:idea: Please read the FAQ and How to Request Help.

nzdreamer55
Posts: 147
Joined: 20 Jul 2012, 23:25

Re: filebot not putting in bindings for VF, VF, AC,AF,etc

Post by nzdreamer55 » 30 Dec 2018, 03:11

Thanks Rednoah. I uninstalled and then installed the universal-jdk8.deb version. Here is what I got

Code: Select all

[email protected]:~/Downloads$ filebot -script fn:sysinfo
FileBot 4.8.2 (r5789)
JNA Native: 5.2.2
MediaInfo: 18.05
7-Zip-JBinding: 9.20
Chromaprint: 1.4.3
Extended Attributes: OK
Unicode Filesystem: OK
Script Bundle: 2018-11-29 (r539)
Groovy: 2.5.1
JRE: OpenJDK Runtime Environment 1.8.0_191
JVM: 64-bit OpenJDK 64-Bit Server VM
CPU/MEM: 1 Core / 955 MB Max Memory / 17 MB Used Memory
OS: Linux (amd64)
HW: Linux linux 4.15.0-43-generic #46-Ubuntu SMP Thu Dec 6 14:45:28 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
DATA: /home/linux/filebot-portable/data/linux
Package: TAR
License: FileBot License PX6482836 (Valid-Until: 2068-12-16)
Done ヾ(@⌒ー⌒@)ノ
Looks like the mediainfo will now work, but it still lists it at 4.8.2 not 4.8.5

Thanks for the solution. It looks like it is getting the bindings now. I am seeing this error though. Could you help me with this?

Code: Select all

Failed to set xattr: FileSystemException: /media/sf_Series.Pool/1Finished/Fawlty Towers/Season 01/Fawlty Towers.S01E01.[360p].[XviD].[MP3].[2ch].A Touch of Class.avi: Error writing extended attribute 'net.filebot.metadata': Operation not supported
Do you think this has to do with permissions of the files?

User avatar
rednoah
The Source
Posts: 16585
Joined: 16 Nov 2011, 08:59
Location: Taipei
Contact:

Re: filebot not putting in bindings for VF, VF, AC,AF,etc

Post by rednoah » 30 Dec 2018, 06:38

1.
It says FileBot 4.8.2 (r5789) which means you're not using the latest revision. Most likely, you now have multiple versions of FileBot installed. Installing mediainfo likely resolved any missing dependency issues you may have had earlier, so now older and newer versions both work.


2.
If the destination filesystem does not support xattr, then you can disable xattr:

Code: Select all

-no-xattr
:idea: viewtopic.php?t=324
:idea: Please read the FAQ and How to Request Help.

Post Reply