No more Subtitles after Opensubtitles hack

Support for Windows users
Post Reply
speelgoedauto2
Posts: 2
Joined: 18 Jan 2022, 15:24

No more Subtitles after Opensubtitles hack

Post by speelgoedauto2 »

Hi Filebot,

Its not possible for me anymore to recieve SUBS frome the subtitle pictogram in the filebot software (4.9.4)
when i try to login i see the following error; OpenSubtitles: 401 Unauthorized

I see on on the opensubtitle website that they are hacked and that we should change our password.
I already did that, but still i do not recieve any subs.

Is there something i can do?

Cheers
kim
Power User
Posts: 1234
Joined: 15 May 2014, 16:17

Re: No more Subtitles after Opensubtitles hack

Post by kim »

Did you remember to tell Filebot of new pw ?
viewtopic.php?p=23813#p23813
Absenm
Posts: 3
Joined: 19 Jan 2022, 00:22

Re: No more Subtitles after Opensubtitles hack

Post by Absenm »

I too am having the same problem getting opensubtitles to accept my new password via Filebot. The new password works fine on their website and even Subdownloader 2.1.1. When I try to change it in GUI I get: "OpenSubtitles: 401 Unauthorized". Again, this is after I changed my password and that password is working just fine everywhere else I have checked.

When I try the command line password change I get:

Code: Select all

> 401 Unauthorized
>redstone.xmlrpc.XmlRpcFault: 401 Unauthorized
>       at net.filebot.web.OpenSubtitlesXmlRpc.checkResponse(Unknown Source)
>       at net.filebot.web.OpenSubtitlesXmlRpc.invoke(Unknown Source)
>       at net.filebot.web.OpenSubtitlesClient$OpenSubtitlesXmlRpcWithRetryAndFloodLimit.lambda$invoke$0(Unknown Source)
>       at net.filebot.web.OpenSubtitlesClient$OpenSubtitlesXmlRpcWithRetryAndFloodLimit.retry(Unknown Source)
>       at net.filebot.web.OpenSubtitlesClient$OpenSubtitlesXmlRpcWithRetryAndFloodLimit.invoke(Unknown Source)
>       at net.filebot.web.OpenSubtitlesXmlRpc.login(Unknown Source)
>       at net.filebot.web.OpenSubtitlesClient.login(Unknown Source)
>       at net.filebot.web.OpenSubtitlesClient$login.call(Unknown Source)
>       at Script1.run(Script1.groovy:12)
>       at net.filebot.cli.ScriptShell.evaluate(Unknown Source)
>       at net.filebot.cli.ScriptShell.runScript(Unknown Source)
>       at net.filebot.cli.ArgumentProcessor.runScript(Unknown Source)
>       at net.filebot.cli.ArgumentProcessor.run(Unknown Source)
>       at net.filebot.Main.main(Unknown Source)
Bikshu
Posts: 1
Joined: 19 Jan 2022, 03:00

Re: No more Subtitles after Opensubtitles hack

Post by Bikshu »

I'm running into this issue as well. And yes I did try to enter my new password using "filebot -script fn:configure" but it is not accepting that new password. I think that's because they have changed their entire TLD from being opensubtitles.org to being opensubtitles.com due to the hack. So it is an entirely new domain, site, and everything... and thus I don't think the login feature for OpenSubtitles that's built into FileBot is attempting to reach the correct servers.
urfin
Posts: 2
Joined: 11 Jul 2018, 05:30

Re: No more Subtitles after Opensubtitles hack

Post by urfin »

I also get exactly the same error message as Absenm on the command line when I try to change the password with the script.
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

FileBot 4.9.4 and earlier only store the MD5 hash of the password you enter via filebot -script fn:configure and thus uses the MD5 hash as password, instead of sending your password verbatim over the internet.

Subtitles API wrote:Important: for security improvement, you can use HTTPS and/or send $password as MD5($password) hash.
https://trac.opensubtitles.org/projects ... LRPC#LogIn


Presumably, this mode of login is no longer possible due to server-side changes in how passwords are stored and verified:
https://forum.opensubtitles.org/viewtopic.php?t=17685


:arrow: FileBot 4.9.5 (r9072) and higher fix the problem by storing your password verbatim and using it for login requests. There is no workaround for older versions.



EDIT:
rednoah wrote: 20 Jan 2022, 00:26 filebot -script fn:configure should just work again since the script jar updates automatically, so CLI method should work again, but the GUI method can't be fixed.
:idea: Please read the FAQ and How to Request Help.
Absenm
Posts: 3
Joined: 19 Jan 2022, 00:22

Re: No more Subtitles after Opensubtitles hack

Post by Absenm »

I am using the latest portable beta 4.9.5 (dated 1-18-22). Now it is actually saying "Sorry. OpenSubtitles Login now requires FileBot 4.9.5 (r9072) or higher due to server-side API changes." which is new. And entering the password in app continues to say "OpenSubtitles: 401 Unauthorized".
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

What does filebot -script fn:sysinfo say?
:idea: Please read the FAQ and How to Request Help.
Absenm
Posts: 3
Joined: 19 Jan 2022, 00:22

Re: No more Subtitles after Opensubtitles hack

Post by Absenm »

Looks like the problem is resolved with the most recent beta. What I downloaded last night after you posted the link above was r9071 when I did fn:sysinfo. I redownloaded the file this morning and now it says r9073 and is accepting my new password. I must have jumped the gun slightly with the download last night and the release number wasn't displayed anywhere. So thanks for the commandline tip. Now everything seem good. Thanks for your help.
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

I see. No worries. My forum post might have been before the new builds finished uploading.
:idea: Please read the FAQ and How to Request Help.
kim
Power User
Posts: 1234
Joined: 15 May 2014, 16:17

Re: No more Subtitles after Opensubtitles hack

Post by kim »

fix the problem by storing your password verbatim and using it for login requests.
Do you mean store in "clear text" ?

If yes, can't you just edit the settings file ?
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

kim wrote: 19 Jan 2022, 17:37 Do you mean store in "clear text" ? If yes, can't you just edit the settings file ?
Yes. That's a good idea. If you manually modify the preferences (e.g. Registry on Windows) then you might be able to modify the password. That should allow you to bypass the MD5 step. Untested though.


:arrow: You could try Export your User Data. Then modify the preferences.backup.xml file. Then do Restore User Data and selected the modified xml file:
viewtopic.php?t=4205


EDIT:

Yep. That works! I've updated the configure script to do just that:
https://github.com/filebot/scripts/comm ... 25da3e646a

:arrow: That'll work for older versions and revisions, so filebot -script fn:configure should just work again since the script jar updates automatically, so CLI method should work again, but the GUI method can't be fixed.
:idea: Please read the FAQ and How to Request Help.
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

:idea: Please read the FAQ and How to Request Help.
kim
Power User
Posts: 1234
Joined: 15 May 2014, 16:17

Re: No more Subtitles after Opensubtitles hack

Post by kim »

cool, so this bypasses the MD5 encode and store it in "clear text" ?
maybe people need to clear cache to force the script update
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

kim wrote: 20 Jan 2022, 05:46 cool, so this bypasses the MD5 encode and store it in "clear text" ?
Pretty much. Just store the password in clear text into the registry directly, instead of doing md5(password) and then storing the result of that. FileBot uses whichever value for the login request, and fortunately there's only one login method in the OpenSubtitles API which used to accept either password or md5(password) in the past.

kim wrote: 20 Jan 2022, 05:46 maybe people need to clear cache to force the script update
filebot -script fn:sysinfo should say Script Bundle: 2022-01-20 (r791) but one can always run the latest script directly from GitHub via filebot -script dev:configure when in doubt.
:idea: Please read the FAQ and How to Request Help.
ttwaro
Posts: 9
Joined: 25 Feb 2020, 09:57

Re: No more Subtitles after Opensubtitles hack

Post by ttwaro »

I have just noticed that I am still receiving this error and I am at the latest stable version.

Code: Select all

$ filebot -script dev:configure
Enter OpenSubtitles username: ************
Enter OpenSubtitles password: ************
Set OpenSubtitles login details
Checking... 401 Unauthorized
Done ヾ(@⌒ー⌒@)ノ

Code: Select all

$ filebot -script fn:sysinfo
FileBot 4.9.6 (r9125)
JNA Native: 5.2.2
MediaInfo: 19.09
Tools: fpcalc/1.4.3 7z/16.02 unrar/5.61
Extended Attributes: OK
Unicode Filesystem: OK
GVFS: PlatformGVFS [/run/user/1000/gvfs]
Script Bundle: 2022-03-18 (r810)
Groovy: 3.0.9
JRE: OpenJDK Runtime Environment 11.0.14
JVM: OpenJDK 64-Bit Server VM
CPU/MEM: 1 Core / 733 MB Max Memory / 23 MB Used Memory
OS: Linux (amd64)
HW: Linux tom-vpn 5.4.0-104-generic #118-Ubuntu SMP Wed Mar 2 19:02:41 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
CPU/MEM: Intel(R) Core(TM) i7 CPU         930  @ 2.80GHz [MemTotal: 3.0 GB | MemFree: 103 MB | MemAvailable: 1.1 GB | SwapCached: 20 MB | SwapTotal: 1.5 GB | SwapFree: 179 MB]
STORAGE: NONE
USER: ttwaro
DATA: /home/ttwaro/.filebot
Package: DEB
License: FileBot License P34415502 (Valid-Until: 2023-03-11)
Done ヾ(@⌒ー⌒@)ノ
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

Did you change / reset your password on OpenSubtitles yet? Passwords set before the hack no longer work. You'll have to reset your password on the OpenSubtitles website first.


:idea: OpenSubtitles sometime just doesn't work, but at this point in time, I can confirm that it works:

Code: Select all

$ filebot -script fn:configure --def osdbUser=$USERNAME --def osdbPwd=$PASSWORD
Set OpenSubtitles login details
Checking... OK
:idea: Please read the FAQ and How to Request Help.
ttwaro
Posts: 9
Joined: 25 Feb 2020, 09:57

Re: No more Subtitles after Opensubtitles hack

Post by ttwaro »

Yes, I did change my password on OpenSubtitles. I just tried the command you showed and it still failed.

Code: Select all

$ filebot -script fn:configure --def osdbUser=****** --def osdbPwd=*******
Set OpenSubtitles login details
Checking... 401 Unauthorized
Done ヾ(@⌒ー⌒@)ノ
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

401 Unauthorized would typically suggest that the username / password is incorrect.
:idea: Please read the FAQ and How to Request Help.
ttwaro
Posts: 9
Joined: 25 Feb 2020, 09:57

Re: No more Subtitles after Opensubtitles hack

Post by ttwaro »

I changed my password again on OpenSubtitles.com, logged off and logged back on successfully with the new password. I again tried updating filebot with it but filebot still gives me the 401 error. I absolutely know that I am giving it the right username / password. It isn't a big deal but I just thought you would want to know that this still isn't working for me and perhaps others out there as well.

Just as an FYI, I am a Linux Mint user. I don't know if that would make a difference or not with how your checking works.

Thanks for your help and for all that you do for filebot. It is a great time saver.
User avatar
rednoah
The Source
Posts: 20845
Joined: 16 Nov 2011, 08:59

Re: No more Subtitles after Opensubtitles hack

Post by rednoah »

You need to set your password for the main OpenSubtitles site. If your login details work there, then they'll also work with the OpenSubtitles XML-RPC API that FileBot is using to login and check for subtitles:
https://www.opensubtitles.org/


:!: Make sure that you're not using the new site. The new OpenSubtitles site is completely separate, and user login details are not shared with the main site:
https://www.opensubtitles.com/
:idea: Please read the FAQ and How to Request Help.
ttwaro
Posts: 9
Joined: 25 Feb 2020, 09:57

Re: No more Subtitles after Opensubtitles hack

Post by ttwaro »

FYI: I finally got it to work. The problem was that I was using www.opensubtitles.com instead of www.opensubtitles.org. Once I changed my password on www.opensubtitles.org and then ran the filebot configuration script it worked. You should make that clear in your documentation. Again, thanks for your help.

Code: Select all

$ filebot -script fn:configure
Enter OpenSubtitles username: [email protected]
Enter OpenSubtitles password: Jelly-Beans51
Set OpenSubtitles login details
Checking... OK

limit_check_by: user_id
user_id: **********
global_24h_download_limit: 200
client_ip: ***.***.***.***
client_24h_download_count: 0
client_download_quota: 200
client_24h_download_limit: 200
Done ヾ(@⌒ー⌒@)ノ
Post Reply