[OpenSubtitles] 401 Unauthorized

Any questions? Need some help?
Post Reply
User avatar
rednoah
The Source
Posts: 20866
Joined: 16 Nov 2011, 08:59

[OpenSubtitles] 401 Unauthorized

Post by rednoah »

FileBot 4.9.4 and earlier only store the MD5 hash of the password you enter via filebot -script fn:configure and thus uses the MD5 hash as password, instead of sending your password verbatim over the internet.

Subtitles API wrote:Important: for security improvement, you can use HTTPS and/or send $password as MD5($password) hash.
https://trac.opensubtitles.org/projects ... LRPC#LogIn


Presumably, this mode of login is no longer possible due to server-side changes in how passwords are stored and verified:
https://forum.opensubtitles.org/viewtopic.php?t=17685

Code: Select all

401 Unauthorized
redstone.xmlrpc.XmlRpcFault: 401 Unauthorized
      at net.filebot.web.OpenSubtitlesXmlRpc.checkResponse(Unknown Source)
      at net.filebot.web.OpenSubtitlesXmlRpc.invoke(Unknown Source)
      ...
      net.filebot.web.OpenSubtitlesXmlRpc.login(Unknown Source)
      ...



UPDATE: 20 Jan 2022
• The configure script has been updated and will now correctly configure the OpenSubtitles login details for all FileBot 4.* versions, so filebot -script fn:configure will just work again.
• The Image Login button in the GUI no longer works in older versions, but you can use filebot -script fn:configure from the command-line instead. The entered login details will work for both GUI and CLI. Please press WIN+R and then paste filebot -script fn:configure to run the command.



UPDATE: 28 Mar 2022
• You must use your username and password from www.opensubtitles.org (main site) and not www.opensubtitles.com (beta site) because login details are not interchangeable between the two sites.
:idea: Please read the FAQ and How to Request Help.
Post Reply