Set Filebot to ONLY process 4K

Support for Windows users
Post Reply
BillyTheKid
Posts: 26
Joined: 19 Dec 2019, 17:15

Set Filebot to ONLY process 4K

Post by BillyTheKid »

Hi,

Is it possible to set Filebot to only run on movies which include a specific string e.g 4K?

At present my Filebot call looks like the below.

Code: Select all

C:\Users\User\Downloads\FileBot_4.9.6-portable\filebot -script fn:amc --conflict auto --output "Z:/Shared Videos/Video" --action duplicate -non-strict "Z:/Shared Videos/Torrent/2_Completed" --log-file amc.log --def ignore="S\d+E\d+|\d+x\d+" --def excludeList=amc.txt --def movieFormat="{fn =~ /2160|UHD|4K/ ? '4K Movies' : fn =~ /UFC|ufc/ ? 'UFC' : 'Movies'}/{plex.tail}" seriesFormat={plex} unsorted=y
I’d like Filebot to only process 4K and UFC content.

Is this possible?

Could the filter function be used to achieve this?

Thanks a lot!
User avatar
rednoah
The Source
Posts: 21315
Joined: 16 Nov 2011, 08:59

Re: Set Filebot to ONLY process 4K

Post by rednoah »

If the --def ignore script parameter doesn't work well (i.e. negative regex match is possible but tricky) then you can use the --file-filter option like so:

Code: Select all

--file-filter "f =~ /4K|UFC/"

:idea: Please read How to process only specific kinds of files?
for details.
:idea: Please read the FAQ and How to Request Help.
BillyTheKid
Posts: 26
Joined: 19 Dec 2019, 17:15

Re: Set Filebot to ONLY process 4K

Post by BillyTheKid »

Hi,

I just tried this;

Code: Select all

C:\Users\User\Downloads\FileBot_4.9.6-portable\filebot -script fn:amc --conflict auto --output "Z:/Shared Videos/Video" --action duplicate -non-strict "Z:/Shared Videos/Torrent/2_Completed" --log-file amc.log --file-filter "f =~ /2160|UHD|4K|UFC|ufc/" --def ignore="S\d+E\d+|\d+x\d+" --def excludeList=amc.txt --def movieFormat="{fn =~ /2160|UHD|4K/ ? '4K Movies' : fn =~ /UFC|ufc/ ? 'UFC'}/{plex.tail}" seriesFormat={plex} unsorted=y
Against this file;

Code: Select all

The.Batman.2022.2160p.UHD.BluRay.x265.10bit.HDR.DTS-HD.MA.TrueHD.7.1.Atmos-SWTYBLZ.mkv
And it is returning;

Code: Select all

Run script [fn:amc] at [Sun Aug 07 18:16:14 BST 2022]
Parameter: ignore = S\d+E\d+|\d+x\d+
Parameter: excludeList = amc.txt
Parameter: movieFormat = {fn =~ /2160|UHD|4K/ ? '4K Movies' : fn =~ /UFC|ufc/ ? 'UFC'}/{plex.tail}
Parameter: seriesFormat = {plex}
Parameter: unsorted = y
Parameter: gmail = *****
Use excludes: Z:\Shared Videos\Video\amc.txt (28)
No files selected for processing
Done ¯\_(?)_/¯
Do you know what i am doing wrong? Am i using the file-filter argument in the right way?

Thanks!
BillyTheKid
Posts: 26
Joined: 19 Dec 2019, 17:15

Re: Set Filebot to ONLY process 4K

Post by BillyTheKid »

In fact i think your answer in this post (viewtopic.php?p=56951) about folders and subfolders is the reason it isn't working for me...
User avatar
rednoah
The Source
Posts: 21315
Joined: 16 Nov 2011, 08:59

Re: Set Filebot to ONLY process 4K

Post by rednoah »

BillyTheKid wrote: 07 Aug 2022, 17:21 In fact i think your answer in this post (viewtopic.php?p=56951) about folders and subfolders is the reason it isn't working for me...
Yep. Looks like it. Just add -r as well then:

Code: Select all

-r
:idea: Please read the FAQ and How to Request Help.
BillyTheKid
Posts: 26
Joined: 19 Dec 2019, 17:15

Re: Set Filebot to ONLY process 4K

Post by BillyTheKid »

rednoah wrote: 07 Aug 2022, 17:42
BillyTheKid wrote: 07 Aug 2022, 17:21 In fact i think your answer in this post (viewtopic.php?p=56951) about folders and subfolders is the reason it isn't working for me...
Yep. Looks like it. Just add -r as well then:

Code: Select all

-r
Awesome that worked!
Post Reply